Page 1 of 1

ScienceBirds - levels won't load

PostPosted: Wed Jul 12, 2017 12:07 am
by Cejkis
Loading levels doesn't seem to work for me - there are no levels at the level
selection screen. I have ubuntu mate 16.04 64bit. My friend has the same system (except not mate) and it works fine for him. (The pre-compiled version)
In unity I see there is an error when I go to level selection screen (see the image). Perhaps I'm missing some library?
Image
Image

Re: ScienceBirds - levels won't load

PostPosted: Wed Jul 12, 2017 5:09 pm
by stepmat-admin
Thank you for bringing this problem to light.
Unfortunately I cannot currently replicate the bug...
I have installed a 32-bit version of the Ubuntu Mate 16.04.2 distribution within a virtual box this morning and am able to load and play the levels from the pre-compiled build without any trouble.
Could you please ensure that you have all the required libraries for Unity installed and updated, and that all the relevant permissions are granted.
Otherwise I would suggest trying a different version of Ubuntu and seeing if the error persists.
Cheers,
Matthew (AIBIRDS ADMIN)

Capture.PNG
Capture.PNG (159.25 KiB) Viewed 1922 times

Re: ScienceBirds - levels won't load

PostPosted: Wed Jul 12, 2017 8:52 pm
by Cejkis
Thank you for reply, I found a dirty quick fix: I replaced all value loading call from LevelLoader.cs with "reader.Value.Replace(".",",")" - For some reason it expects decimal numbers with "," because of my language.
Looks good now.
My libraries are fine, it seems.

Code: Select all
ldd ./ScienceBirds.x86_64
   linux-vdso.so.1 =>  (0x00007ffd85963000)
   libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f70307a4000)
   libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f7030587000)
   librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f703037e000)
   libGL.so.1 => /usr/lib/nvidia-375/libGL.so.1 (0x00007f70300ee000)
   libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f702fdb4000)
   libXcursor.so.1 => /usr/lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f702fba9000)
   libXrandr.so.2 => /usr/lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f702f99e000)
   libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f702f61c000)
   libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f702f312000)
   libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f702f0fc000)
   libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f702ed32000)
   /lib64/ld-linux-x86-64.so.2 (0x000055dbc1241000)
   libGLX.so.0 => /usr/lib/nvidia-375/libGLX.so.0 (0x00007f702eb01000)
   libGLdispatch.so.0 => /usr/lib/nvidia-375/libGLdispatch.so.0 (0x00007f702e818000)
   libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f702e5f6000)
   libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f702e3eb000)
   libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f702e1e5000)
   libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f702dfd3000)
   libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f702ddce000)
   libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f702dbc8000)

Re: ScienceBirds - levels won't load

PostPosted: Thu Jul 13, 2017 12:55 am
by stepmat-admin
Thanks for finding this fix.
I'll look further into it and hopefully this will be sorted in the next update.
Yes your libraries seem fine, not sure of the exact cause of the problem but at least its working for now.
Cheers,
Matthew (AIBIRDS ADMIN)